Plugin Cafe Homepage
Forum Home Forum Home > Plugin Cafe > SDK Help
  New Posts New Posts
  FAQ FAQ  Forum Search

Shader not updating in material

Author
Message
  Topic Search Topic Search
NEON View Drop Down
Member
Member


Joined: 2015 Jul 23
Location: Austria
Online Status: Offline
Posts: 70
Direct Link To This Post Topic: Shader not updating in material
    Posted: 2018 Mar 23 at 10:38am

User Information:

Cinema 4D Version:   R18.057 
Platform:   Windows  ;   
Language(s):     C++  ;  XPRESSO  ;  PYTHON  ; 

---------

Hello PluginCafe,

I have a weird problem when I am using my shader in a material.
I have a time-dependent shader which should recalculate/update on every frame. When I am using my shader in a Displacer everything works fine, and the shader is updated properly. However, when I use the shader in an actual material, it does not get updated at all.

Does anybody now the reason for this?

regards,
Florian

Back to Top
Andreas Block View Drop Down
Forum Moderator
Forum Moderator
Avatar

Joined: 2014 Oct 01
Location: Hannover
Online Status: Offline
Posts: 1878
Direct Link To This Post Posted: 2018 Mar 26 at 2:03am
Hello Florian,

can you please be a bit more specific? What do you mean, with "updated properly" and "not updating at all"? During rendering? In the viewport?
In case of the viewport, is there a difference, when setting the "Animate Preview" checkbox on the "Editor" tab of the material?

Cheers,
Andreas
SDK Support Engineer
Back to Top
NEON View Drop Down
Member
Member


Joined: 2015 Jul 23
Location: Austria
Online Status: Offline
Posts: 70
Direct Link To This Post Posted: 2018 Apr 06 at 10:09am
Hello Andreas,
sorry for the very late reply!

The problem was only in the viewport. A client of mine told me that it did not update, turns out, it really was only in the viewport and worked fine while rendering, which he did not tell me.  

Again, sorry taking so long to reply!

best regards,
Florian
Back to Top
Andreas Block View Drop Down
Forum Moderator
Forum Moderator
Avatar

Joined: 2014 Oct 01
Location: Hannover
Online Status: Offline
Posts: 1878
Direct Link To This Post Posted: 2018 Apr 09 at 2:12am
Hi Florian,

no worries. So, is your problem solved then?

Cheers,
Andreas
SDK Support Engineer
Back to Top
NEON View Drop Down
Member
Member


Joined: 2015 Jul 23
Location: Austria
Online Status: Offline
Posts: 70
Direct Link To This Post Posted: 2018 Apr 10 at 8:38am
Hi Andreas, 

yes it is solved, thank you!
Back to Top

Forum Jump Forum Permissions View Drop Down

Bulletin Board Software by Web Wiz Forums® version 9.61 [Free Express Edition]
Copyright ©2001-2009 Web Wiz

This page was generated in 0.109 seconds.